Profanity Illustration

User Guide

Installation Guide

Contents

Linux/*BSD

ALT packages.altlinux.org
Arch archlinux.org
aur.archlinux.org
Debian packages.debian.org
Exherbo git.exherbo.org
Funtoo funtoo.org
Gentoo packages.gentoo.org
github.com optmzr
GNU Guix guix.gnu.org
openSUSE software.opensuse.org
Slackware slackbuilds.org
Ubuntu packages.ubuntu.org
Nix/NixOS nixos.org/nixos/packages.html
github.com/NixOS/nixpkgs/
FreeBSD www.freebsd.org
OpenBSD
pkg_add profanity

To add to this list, submit a pull request to the website source, or email the Mailing list with details.

Mac OS X

Homebrew

To install profanity using homebrew:

brew install profanity

To ensure you have all features supported profanity -v should show the following:

Desktop notification support: Enabled
OTR support: Enabled
PGP support: Enabled
C plugins: Enabled
Python plugins: Enabled

To install the latest development version, use the tap supplied by robsalasco at Github available here:

brew tap robsalasco/homebrew-profanity
brew install profanity --HEAD

Macports

A howto using macports has also been written by louiecaulfield at Github available here.

Windows

On Windows you can either install Profanity over the Windows Subsystem for Linux or via Cygwin.

WSL

The Windows Subsystem for Linux is available since Windows 10 only.

Please read the documentation provided by Microsoft on what WSL is and how to install it

You will have to choose an distribution that you install (Debian, openSUSE, Ubuntu..) and then install Profanity via the distributions package manager. We recommend to choose a distribution that you are already familiar with or one where you can find a lot of documentation and help online (Debian, openSUSE). Another point to consider is which stable version of Profanity is available in the distributions repositories. One way to find this is out is to check Repology.

Cygwin

Install Cygwin by downloading and running its installer:

64Bit Systems: http://cygwin.com/setup-x86_64.exe

32bit Systems: http://cygwin.com/setup-x86.exe

Dependencies

wget and unzip are required to install Profanity. When running setup.exe, search for and add them when asked to select packages.

Note: To make use of OTR and OMEMO support on Cygwin, libotr and libsignal-protocol-c need to be build from source, since they are not part of the Cygwin repository.

Download and Install

Download the zip archive from the homepage and extract it, then download the install script and run it in the project directory:

wget https://profanity-im.github.io/profanity-0.7.1.zip
unzip profanity-0.7.1.zip
cd profanity-0.7.1
wget https://profanity-im.github.io/install-all.sh
chmod u+x install-all.sh
./install-all.sh

The script will install the neccessary build dependencies for Profanity using apt-cyg. Download, build and install libmesode and then build and install Profanity. Make sure to read the script before executing it.

Android

Profanity is included as a Termux package on Android. Install Termux from F-Droid.

Update the package list and install Profanity:

apt update
apt install profanity